Back to overview
Degraded

Performance Degradation

Nov 20 at 07:21am HST
Affected services
Client Portal WEB
Client Portal API

Resolved
Nov 20 at 08:03am HST

This issue has been resolved, and everything is operating as expected.

Updated
Nov 20 at 07:38am HST

We’ve seen the metrics return to normal levels. We’re continuing to monitor the situation and will keep you updated.

Created
Nov 20 at 07:21am HST

Our team is aware of the current performance degradation affecting the platform. We are actively monitoring system behavior to assess whether this is a temporary spike or a larger issue. Updates will follow as we learn more.