Back to overview
Degraded

High Origin Latency & Backend Exhaustion

Nov 26 at 06:30am HST
Affected services
Client Portal WEB
Client Portal API

Resolved
Nov 26 at 07:50am HST

This issue has been resolved, and everything is operating as expected.

Updated
Nov 26 at 06:57am HST

We’ve identified an actionable cause of the performance degradation and passed it to our development team. A manual workaround has been applied, and the platform should now be performing normally. We’re continuing to monitor the situation and will keep you updated.

Created
Nov 26 at 06:30am HST

Our team is aware of the current performance degradation affecting the platform. We are actively monitoring system behavior to assess whether this is a temporary spike or a larger issue. Updates will follow as we learn more.